I figured this out by luck but I'm glad to say that this is the fix. When I try to assign buttons by recording, I can only do it for gamepad 2. If this scenario is applicable, you should be able to resolve the issue by ensuring that your controller gets detected first.

However, if one (or more) of the above is not true, the controller won't work without a 3rd-party gamepad software. Last but not the least use x360ce For those who are unaware: x360ce is Xbox 360 Controller Emulator which will make your controller work as Xbox 360 Controller. The Xbox One/360 controller works fairly flawlessly in my experience. I managed to fix that but Yakuza 0 still won't detect x360ce.. In this tutorial, you will find steps to make controller (gamepad, joystick) work with Call of Duty: Warzone. I’m curious if this is a controller type problem or if roblox is just having trouble detecting any type of controller connected. R8. Configure layout for controller remapping and save it. Method #1 Start the game, at the main menu there are three lines at the bottom left corner (a hamburger looking thing) click on that and go to settings> General> and it will let you change input device to controller from there. So it seems the gamepad is really detected as gamepad 2.

However, it simply does not work. It still didn't recognize the controller ingame, but depending on the game you might need to rename the created xinput dll to either: xinput1_1.dll
At launch, x360ce detect it 2 times in a row, as gamepad 1 and then as gamepad 2.

It has worked before on another PC on dark souls with same controller. If your controller works with X360ce all you need to do is find the right XInput Files to select. I don’t. Obviously, this is a problem since gamepad1 is used in games. Note that for "wireless" controllers you have to have either a dongle or cable for them to work.
USB Headphones are detected as a controller – Certain USB headsets (particularly HyperX models) have the potential of being seen as controllers by Rocket League. See my post #15 above for a link to them. Also, does the game work OK without x360ce?-Tried on witcher 2 but it didn't work. Even messing with controller settings in Steam doesn't help. R10. The x360ce.exe application is just a GUI for editing x360ce.ini and testing your controller. Do you have access to any other controllers? How to use x360ce I've even tried switching usb ports for my controller and even updating the version of x360ce but nothing. Can you get x360ce to work on any other games? This was not the case however, they are gone for good. 32/64-bit depends on the X360ce application.


Switching the controlers ID in ini files did not seem to work. Is your controller set-up with x360ce?-yes, “New Device Detected” and searched automatically, files were found. It was listed in Device Manager, so I decided to right click and uninstall all the controller drivers from the Device Manager hoping it would reinstall them and work properly.

I mean, I don’t have the USB dongle needed. #336 x360ce will not detect Hori EX2 Turbo controller Status: Duplicate Owner: nobody So I tried again, messed with x360ce, and eventually Yakuza 0 would not detect the controller at all. Look at my screenshot. So in short, nothing relating to any controller is showing up in the Device Manager. If [Controller #] tab page light won't turn green / Red light on [Controller #] tab page: • The controller profile loaded may match the name of your controller, but not actually be for the controller you own.